ФЭНДОМ


Загрузки: $wgFileBlacklist
Файлы с этими расширениями недопустимы при загрузке.
Появилось, начиная с версии: 1.2.0
Удалено в версии: ещё используется
Допустимые значения:
Значение по умолчанию: (см. ниже)

Другие настройки: По алфавиту | По функциональности

Детали Править

Файлы с этими расширениями недопустимы при загрузке.

  $wgFileBlacklist = array(
  # HTML may contain cookie-stealing JavaScript and web bugs
  'html', 'htm', 'js', 'jsb', 'mhtml', 'mht',
  # PHP scripts may execute arbitrary code on the server
  'php', 'phtml', 'php3', 'php4', 'php5', 'phps',
  # Other types that may be interpreted by some servers
  'shtml', 'jhtml', 'pl', 'py', 'cgi',
  # May contain harmful executables for Windows victims
  'exe', 'scr', 'dll', 'msi', 'vbs', 'bat', 'com', 'pif', 'cmd', 'vxd', 'cpl' );

История изменений Править

  • 'cgi' было добавлено в 1.3.8
  • 'js' и 'jsb' добавлено в 1.5.0
  • 'php5' было добавлено в 1.8.0

См. также Править