ФЭНДОМ


'Эта функциональность устарела и не должна использоваться с текущей версией MediaWiki .'</ SPAN>
Эта функциональность устарела (или, возможно, полностью удалена) в версии (((1))).

(((2 |}}}</ DIV>
Доступ участников: $wgWhitelistEdit
Если true, участники должны представиться системе, чтобы править.
Появилось, начиная с версии: 1.1.0
Удалено в версии: 1.5.0
Допустимые значения: булевские значения
Значение по умолчанию: false

Другие настройки: По алфавиту | По функциональности

Детали Править

Если true, участники должны представиться системе, чтобы править.

Это не 100% безопасно, может быть дыра в безопасности, если использовать один этот параметр. Используйте на свой страх и риск.

Mediawiki версии 1.5 и выше Править

Эта установка не рекомендуется в версии 1.5.0, и заменяется $wgGroupPermissions, разрешением 'edit'.

Для имитации эффекта:

   $wgWhitelistEdit = true;

установите:

   $wgGroupPermissions['*']['edit'] = false;

Если $wgWhitelistRead установлено, вы также должны отключить разрешение 'read' для вступления в силу эффекта для анонимных участников:

   $wgWhitelistRead = array( "Main Page", "Special:Userlogin" );
   $wgGroupPermissions['*']['read'] = false;

См. также Править